【安全预警】Apache Solr 错误默认配置远程代码执行漏洞(CVE-2019-12409)

TCSA-2019-0043

扫描二维码查看详情

情报概览

类型介绍
风险等级高危
CVSS 评分8.8
CVE 编号CVE-2019-12409
情报概述腾讯云安全中心监测到 Apache Solr 官方披露了一个由于错误的默认配置导致的远程代码执行漏洞(CVE-2019-12409),该漏洞影响 Linux 版本的 Solr 服务,被攻击者利用可进行远程代码执行攻击
情报类型远程代码执行
收录时间2019-11-19 11:47:06

情报详情

近日,Apache Solr 官方发布安全公告,披露了 Linux Solr 8.1.1 ~ 8.2.0 版本上存在的一处错误默认配置导致的高危安全漏洞,该漏洞由于默认配置文件 solr.in.sh 中 ENABLE_REMOTE_JMX_OPTS 配置不合理所致,当使用受影响版本的 solr.in.sh 默认配置文件时,JMX 监控将开启且 RMI 端口会对外未授权开放(默认值为 18983),如果防火墙或安全组未作任何访问控制,具备 Solr 节点访问权限的攻击者可通过 JMX 上传恶意代码到 Solr 服务器达到执行代码的目的。

影响版本

Apache Solr 8.1.1 ~ 8.2.0(Linux 版本)

安全版本

该漏洞由于 Solr 配置文件配置项错误配置导致,官方暂未发布新版本,用户可通过修改默认配置项进行修复。

检测方法

检查 Linux Solr 节点版本大小及默认配置文件 solr.in.sh 中 ENABLE_REMOTE_JMX_OPTS 值是否为 true,若为 true,则说明可能受影响,反之,则不受影响。

修复建议

  1. 检查每个 Solr 节点的默认配置文件 solr.in.sh,将 ENABLE_REMOTE_JMX_OPTS 值设置为 false,并重启 Solr 服务生效;
  2. 配置安全组,避免将 Solr 服务暴露在不受信任的外部网络环境。

参考链接

Last modification:January 9th, 2020 at 11:21 pm
If you find my article useful, please feel free to appreciate it.